Keyword

Topic-icon Only Software audio device

More
11 years 11 months ago #5195 by resonansER
Replied by resonansER on topic Only Software audio device
I solved this problem! Yeessss!!!
Tip:
When you write to this line
HKEY_CURRENT_USER \ Software \ Volition \ WingCommanderSaga

"Generic Software"

DO NOT LAUNCH GAME FROM LAUNCHER (BECAUSE LAUNCHER TURN OFF you changes), ONLY FROM wcsaga_sse2.exe and ALL BE alright!

I have sound now!

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5196 by corder2000
Replied by corder2000 on topic Only Software audio device
I have the same problem as the resonansER...

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5197 by resonansER
Replied by resonansER on topic Only Software audio device

corder2000 wrote: I have the same problem as the resonansER...


Read my previous post. I solved this problem ;)

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5218 by IoG
Replied by IoG on topic Only Software audio device

resonansER wrote: I solved this problem! Yeessss!!!
Tip:
When you write to this line
HKEY_CURRENT_USER \ Software \ Volition \ WingCommanderSaga

"Generic Software"

DO NOT LAUNCH GAME FROM LAUNCHER (BECAUSE LAUNCHER TURN OFF you changes), ONLY FROM wcsaga_sse2.exe and ALL BE alright!

I have sound now!


It's work for me too

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5237 by tolwyn
Replied by tolwyn on topic Only Software audio device
I'll send you updated launcher, guys via PM once I am able. Please give it a whirl and tell us if it solves your no sound problem!

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5240 by tolwyn
Replied by tolwyn on topic Only Software audio device
Updated launcher is underway. Give it a whirl!

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5252 by AerTobeGuru
Replied by AerTobeGuru on topic Only Software audio device
I made everything too as resonansER, everything earned :-) I will wait correction.

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5257 by resonansER
Replied by resonansER on topic Only Software audio device

AerTobeGuru wrote: I made everything too as resonansER, everything earned :-) I will wait correction.


Maybe you haven't installed openAL?

Please Log in or Create an account to join the conversation.

More
11 years 11 months ago #5261 by AerTobeGuru
Replied by AerTobeGuru on topic Only Software audio device

resonansER wrote:

AerTobeGuru wrote: I made everything too as resonansER, everything earned :-) I will wait correction.


Maybe you haven't installed openAL?


No, I a feather installed game and the program 3-4 times but result there was the same. I think that it is connected with Window 7 X64.

Please Log in or Create an account to join the conversation.

  • KeldorKatarn
  • KeldorKatarn's Avatar
  • Visitor
  • Visitor
11 years 11 months ago #5275 by KeldorKatarn
Replied by KeldorKatarn on topic Only Software audio device
Edit:

Ok people I've looked into this. This is the situation as best as I could find out:

Windows dropped DirectSound3D support in Vista and newer Windows versions. That means that OpenAL can only support Hardware devices for soundchips that natively support OpenAL hardware acceleration. That seems to be the case for several Creative Labs chips but Realtek chips (a lot of the onboard stuff like mine e.g.) seems to have no support for it. So on those it will fallback on the Software Device which uses a Software Renderer for stuff like EAX and sourround sound.

Please Log in or Create an account to join the conversation.

Moderators: TParisdamsonThorarisian
Time to create page: 0.172 seconds