Keyword

Topic-icon Game doesn't start, two error messages

  • hellas76
  • hellas76's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 3 months ago #9512 by hellas76
Game doesn't start, two error messages was created by hellas76
Hi everybody, everything fine during installation, the launcher takes me to the game options screen but when I click RUN I got this message first:

"Unable to get proper pixel format for OpenGL w32"

I click ok and then the second one:

Unable to initialize display device!

ntdll.dll! KiFastSystemCallRet
kernel32.dll! WaitForSingleObjectEx + 67 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
wcsaga_sse2.exe! <no symbol>
wcsaga_sse2.exe! <no symbol>
wcsaga_sse2.exe! <no symbol>
kernel32.dll! BaseThreadInitThunk + 18 bytes
ntdll.dll! RtlInitializeExceptionChain + 194 bytes
wcsaga_sse2.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>


Any solution?

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #9516 by Luke
Replied by Luke on topic Game doesn't start, two error messages
Welcome on board hellas76 :)

It seems your graphical environment doesn't have the needed requirements. You need:

OpenGL 2.0>
Shader 3.0>


Please download Debug-Build Support-Tool and activate the following options:

Include system report (DxDiag)

Then press <Start Debug Build and create Support ZIP>. After the Debug Build crash/exit attach here the fs2_open_SupportTool.zip from your desktop.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

  • hellas76
  • hellas76's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 3 months ago - 7 years 11 months ago #9517 by hellas76
Replied by hellas76 on topic Game doesn't start, two error messages
Thanks Luke!!! :D
Here it is!
Last edit: 7 years 11 months ago by Luke. Reason: attachment deleted

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #9521 by Luke
Replied by Luke on topic Game doesn't start, two error messages
Thx for the support zip, i will investigate the issue now. Stand by.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #9522 by Luke
Replied by Luke on topic Game doesn't start, two error messages
Ok, your laptop is really old (2005) and your GPU driver is outdated (2009). It seems also that this driver version doesn't support OpenGL 2.0.

The engine stops exactly at the moment they try to initialize the graphic mode. This means there is a serious problem with the graphic driver. Please try to find a update and don't use the Windows update feature for that, use directly a ATI update.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

  • hellas76
  • hellas76's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 3 months ago #9523 by hellas76
Replied by hellas76 on topic Game doesn't start, two error messages
Unfortunately the driver is updated, simply believe that the GPU is way much outdated... :x

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #9524 by Luke
Replied by Luke on topic Game doesn't start, two error messages
This is also possible, yes. Do you know which GPU your laptop have exactly? If we know this, i can check if this GPU have the needed requirements.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

  • hellas76
  • hellas76's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
9 years 3 months ago #9529 by hellas76
Replied by hellas76 on topic Game doesn't start, two error messages
should be a radeon x300...horrible...

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #9531 by Luke
Replied by Luke on topic Game doesn't start, two error messages
It seems that this GPU/driver have OpenGL 2.0 capabilities, but only Shader 2.x.

WCS needs Shader 3.x, so try the following:

-Start DBST
-Type in the command line box this: -no_glsl
-Press "Start Debug Build..."

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #9573 by basilfawlty
Replied by basilfawlty on topic Game doesn't start, two error messages
I get a similar message but have the excuse that on the very PC under win 7 WCS worked great. My guess is that it is indeed just the opengl and shader definitions under Win8. Does anybody have links where to get the best updates for those ?

Please Log in or Create an account to join the conversation.

Moderators: TParisdamsonThorarisian
Time to create page: 0.157 seconds