Keyword

Topic-icon ATI 5970 and driver issue

More
11 years 10 months ago #6492 by dsa44
ATI 5970 and driver issue was created by dsa44
Hey all, I have read all the posts under "game won't run" and would like to summarize here. There is obviously some issue with the ATI HD 5970 card, drivers and (awesome) game. Here is a brief summary.
Game installed fine, and loaded to the main screen but with 11.11c drivers, game crashed to "white screen of death" (wsod) entering campaign or tech info of spacecraft.
Deleted 11.11c drivers, ran driversweeper, and installed 12.3 driver.
Same problem with wsod.
Disabled xfire in ccc...wsod
unchecked "enable surface format optimization" in ccc....wsod
added -no_glsl to the cfg file.....wsod
tried running with wcsaga_no_opt.exe....wsod
ran wcsaga_d.exe and lo and behold, game ran, but only with xfire set to "default mode" in ccc. I understand that this is a debug mode exe, and there may be some anomalies, but at least the game runs now.
If anyone else has found a workaround...please let us all know.
cheers

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #7632 by HappyZippo
Replied by HappyZippo on topic ATI 5970 and driver issue
I am facing the same issue with my 5970 and spent a lot of time testing different mutations of graphics settings in the ccc. The suggestion to generate a game profile without xfire did not work for me. Everything I tried leads to the white screen of death, when I enter the briefing door. I am using the 12.4 catalyst driver.
@development team: are you actually working on that issue or is it low priority as those dual gpu cards are rarely used.

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #7634 by tolwyn
Replied by tolwyn on topic ATI 5970 and driver issue
Runnng the game as admin and/or using the debug build might help.

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #7638 by HappyZippo
Replied by HappyZippo on topic ATI 5970 and driver issue
Running it in admin mode windowed as well as full screen was one of the first things I tried. Nothing helped. I thought the debug build was not supposed to be a playable version concerning the full campaign. Is that right?

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #7640 by tolwyn
Replied by tolwyn on topic ATI 5970 and driver issue
The ATI driver issue is very rare and there is no real pattern as to when or why it occurs. In some cases playing with our debug build helped, in some cases using a different driver iteration solved the issue.

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #7716 by HappyZippo
Replied by HappyZippo on topic ATI 5970 and driver issue
After trying everything proposed I started looking for alternative drivers for the 5970. In the end I came across the DNA-Project. The 10.10e.4 driver works perfectly with the card and the game. It is a modified Catalyst driver with the old ATI interface. I left everything default, in the game settings I handed all controls to the application for the beginning. Here is the link: donotargue.com/note/dna-ati-10-10e-4/
You will find 32-Bit and 64-Bit drivers on the page. Have fun playing this great game.

Please Log in or Create an account to join the conversation.

More
11 years 8 months ago #7808 by Darth Corleone
Replied by Darth Corleone on topic ATI 5970 and driver issue
Thank's HappyZippo for the link to the ati-10-10e-4 video card driver. I was having the same problem with my 5970. I removed the old catalyst and installed the above. Now it loads the Hermes thinggy... thanks Again..DC

Please Log in or Create an account to join the conversation.

More
11 years 8 months ago #7811 by tolwyn
Replied by tolwyn on topic ATI 5970 and driver issue
Fantastic!

Please Log in or Create an account to join the conversation.

More
11 years 8 months ago #7911 by warghost
Replied by warghost on topic ATI 5970 and driver issue
First off, I want to say thanks to everyone who made this game happen, you guys are awesome! And thanks for finding a solution to this problem. Hopefully a permanent fix will be found and a patch can be released soon.

So yeah, I'm having the same problem, with ATI 5970. I looked at the DNA driver suggested, but according to the site, 64-bit systems will require a boot using F8 to disable "Driver Signature Enforcement”, or the driver will not load properly. It says this would have to be done each time my PC is booted. Is that correct? Or would I only have to boot that way once, until the driver is installed?

I have had nothing but problems since I switched over from nVidia to ATI. Countless driver issues, instability with most games, and poor performance compared to nVidia cards. I'll never buy another ATI product, that's for sure.

Please Log in or Create an account to join the conversation.

More
11 years 8 months ago #7914 by HappyZippo
Replied by HappyZippo on topic ATI 5970 and driver issue
Did you try to install the driver already? I did not experience any problems concerning the 64-bit driver signature apart from the fact that BF3 wants me to change the driver. 2D desktop and WC are running perfectly without any further precautions. Just give it a try!
... and ... ATI isn't that bad. You have to keep in mind that the 5970 as dual GPU internal crossfire board is quite special. On the other hand: mine is about 3 years old and still state of the art concerning performance.

Please Log in or Create an account to join the conversation.

Moderators: TParisdamsonThorarisian
Time to create page: 0.152 seconds