Keyword

Topic-icon Video problem on startup

  • KW_Pilot
  • KW_Pilot's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
12 years 3 weeks ago #6275 by KW_Pilot
Video problem on startup was created by KW_Pilot
Error = Unable to get proper pixel format for OpenGL W32!

Unable to initialize display device!

ntdll.dll! ZwWaitForSingleObject + 21 bytes
kernel32.dll! WaitForSingleObjectEx + 67 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
wcsaga_sse2.exe! <no symbol>
wcsaga_sse2.exe! <no symbol>
wcsaga_sse2.exe! <no symbol>
kernel32.dll! BaseThreadInitThunk + 18 bytes
ntdll.dll! RtlInitializeExceptionChain + 54 bytes
wcsaga_sse2.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>


Working on HP Laptop with Windows 7 Pro; 8 GB Ram; i7-2630QM processor; 15.6" Full HD HP Anti-glare LED display /w Radeon HD 6770 switchable graphics with 2048MB GDDR5;

I have installed openAL

I'm sure it is a simple fix, any help would be appreciated!

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #6317 by arisian
Replied by arisian on topic Video problem on startup
What graphics driver version are you using? This sounds to me like a driver problem...make sure you're using the latest drivers (should be Catalyst 12.3 for your card, I think).

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #6356 by pdugousset
Replied by pdugousset on topic Video problem on startup
hi, i've the same problem. but on HP computer we can't use catalyst system directly from AMD because it's a special driver to have switch automatic between card graphic and Intel HD 3000 !!!

so how it s possible to have open gl usable ?
thanks

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #6373 by arisian
Replied by arisian on topic Video problem on startup
I can't speak to that, since I don't have an AMD graphics setup myself, but hopefully one of the devs will be able to come up with something that will work. They've managed to find workarounds for a number of similar issues, but they're pretty busy, so it may take them a couple of days.

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #6376 by tolwyn
Replied by tolwyn on topic Video problem on startup
There isn't much I can say about the issue, since I do not have similar hardware at my disposal. The error message could indicate than either the onboard card is used to start the game or the AMD drivers do not have OpenGL support. That is (or was) a common issue wirh drivers installed via Windows Update.

Please Log in or Create an account to join the conversation.

  • KW_Pilot
  • KW_Pilot's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
12 years 3 weeks ago #6416 by KW_Pilot
Replied by KW_Pilot on topic Video problem on startup
Simple fix... I had to update the Radeon 6770M drivers under the device manager. Starts up just fine now. Thanks.

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #6419 by tolwyn
Replied by tolwyn on topic Video problem on startup
Awesome!

Please Log in or Create an account to join the conversation.

Moderators: TParisdamsonThorarisian
Time to create page: 0.143 seconds