Keyword

Topic-icon Setting speeds

  • shredher
  • shredher's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
12 years 6 days ago #7299 by shredher
Setting speeds was created by shredher
Hi again,

next problem. I can't figure out how to keep a ship at a certain speed. I tried making a shuttle escort mission. So, I order the shuttle to move to a certain Nav (ai-waypoints-once). The problem is, the shuttle accelerates to maximum speed. How can I keep it at, say, 200 kps? And maybe change it again to maximum at some point to escape from enemies?

The "Velocity" attribute in the shuttles "Initial Status" options seems to be overritten, as soon as the shuttle receives the order "ai-waypoints-once".

Please Log in or Create an account to join the conversation.

  • shredher
  • shredher's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
12 years 6 days ago #7301 by shredher
Replied by shredher on topic Setting speeds
DISREGARD THAT!

3 hours of trying to find a freakin' solution... when it was so simple.

I somehow figured that "cap-waypoint-speed" would only be for "Capships" ... due to the "cap"... GRML!

No my shuttle flies at the desired speed.

I refrained from deleting this thread in case anyone else has the same problem ;)

Please Log in or Create an account to join the conversation.

More
12 years 5 days ago #7337 by karajorma
Replied by karajorma on topic Setting speeds

shredher wrote: The "Velocity" attribute in the shuttles "Initial Status" options seems to be overritten, as soon as the shuttle receives the order "ai-waypoints-once".


That one is well named. It is the initial velocity of the ship at the start of the mission (or when it jumps in). It's never going to survive the ship actually deciding to do something. :)

Please Log in or Create an account to join the conversation.

Moderators: TParisdamsonThorarisian
Time to create page: 0.119 seconds