Keyword

Topic-icon Direct Sound Won't Initialize.

  • duploboy
  • duploboy's Avatar Topic Author
  • Offline
  • Spaceman
  • Spaceman
More
1 year 9 months ago #9942 by duploboy
duploboy created the topic: Direct Sound Won't Initialize.
I've seen another topic on here with similar issues but none of the solutions worked for me.

Whenever I try to open I get an error message saying that direct sound couldn't initialize and that I should close any background programs.

I tried installing the new launcher, I reinstalled openAL, I installed the patch. Nothing quite seems to work for me. Have any ideas?

It also won't run unless it is windowed. No idea why.

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #9944 by Luke
Luke replied the topic: Direct Sound Won't Initialize.
I try to help in the evening, i am currently not at home. First i need the DBST data:

[center:3co62h9d]
Create support file[/center:3co62h9d]

1. Please download Debug-Build Support-Tool and activate the following options:

[X] Create a complete inventory

2. Then press <Create support archive only> and attach here the WCS_SupportTool_Data_{name}.7z.
[center:3co62h9d]
[/center:3co62h9d]

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

  • duploboy
  • duploboy's Avatar Topic Author
  • Offline
  • Spaceman
  • Spaceman
More
1 year 9 months ago - 1 year 9 months ago #9946 by duploboy
duploboy replied the topic: Direct Sound Won't Initialize.
Here you go!
Last Edit: 1 year 9 months ago by Luke. Reason: attachment deleted

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #9947 by Luke
Luke replied the topic: Direct Sound Won't Initialize.
Sorry, was bussy this week. I need another file.

1. Please start DBST again and don't change any option but simply click <Start Debug Build and create support archive>.
2. After the Debug Build crash/exit attach here the WCS_SupportTool_Data_{name}.7z.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

  • duploboy
  • duploboy's Avatar Topic Author
  • Offline
  • Spaceman
  • Spaceman
More
1 year 9 months ago - 1 year 9 months ago #9948 by duploboy
duploboy replied the topic: Direct Sound Won't Initialize.
No worries. I appreciate your time. As long as this isn't some elaborate ploy to steal all my personal information. ;)

Here's that data.
Last Edit: 1 year 9 months ago by Luke. Reason: attachment deleted

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #9949 by Luke
Luke replied the topic: Direct Sound Won't Initialize.

duploboy wrote: No worries. I appreciate your time. As long as this isn't some elaborate ploy to steal all my personal information. ;)


I am no data dealer or trojan programmer, only the developer of WCS+. ^^ You can see what you send me if you unpack the archive simply with 7Zip or any other unpacker with 7Zip capabilities. There are no sensible data in the DBST archives, only lot of tech things.

Thx, now i have the most important data. Ok, give me some time for digging in this logs.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

  • duploboy
  • duploboy's Avatar Topic Author
  • Offline
  • Spaceman
  • Spaceman
More
1 year 9 months ago #9950 by duploboy
duploboy replied the topic: Direct Sound Won't Initialize.
I figured as much, I'm just joking a bit. :D

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #9951 by Luke
Luke replied the topic: Direct Sound Won't Initialize.
Ok, i read now all logs:

The WCS installation is okay and OpenAL is correctly installed. The engine try several times to connect to the OpenAL API but without success. Don't know why.

Let's try some:

1. You have OpenAL32.dll in your WCS folder, delete it.
2. Uninstall OpenAL.
3. Reinstall your sound driver.
4. Reinstall OpenAL with oalinst.exe from WCS folder.
5. Try again.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

  • duploboy
  • duploboy's Avatar Topic Author
  • Offline
  • Spaceman
  • Spaceman
More
1 year 9 months ago #9952 by duploboy
duploboy replied the topic: Direct Sound Won't Initialize.
It Worked!

Thanks Luke!

You are magnificent!

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #9953 by Luke
Luke replied the topic: Direct Sound Won't Initialize.
:)

Now to the graphic issue: you have a Intel GPU (HD Graphics 4600). My experience the last years shows, that the Intel GPU isn't the best solution for WCS and there are 3 possibilities, depending to the type of Intel GPU:

1. don't work.
2. works only in windowed mode.
3. works fully.

Tools: Setup ZIP Check & UnZip ...and more
HowTo's: Joystick: configure throttle and rudder ...and more
Projects: WCS+ ...and more

Please Log in or Create an account to join the conversation.

Moderators: TParisdamsonThorarisian
Time to create page: 0.162 seconds